jwildfire.org

The official JWildfire forum
It is currently Wed Dec 11, 2019 10:20 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Tue Nov 19, 2019 4:17 am 
Offline

Joined: Fri Dec 27, 2013 2:18 am
Posts: 74
I occasionally miss the ability to perform a true roll operation in JWildfire. Pitch rotates the flame around the x-axis and yaw rotates it around the z-axis; roll would rotate it around the y-axis. But the control named "Roll" doesn't do that; it rotates the camera. I'd like to add true roll functionality, but would like some opinions about naming.

First question: Would it be too confusing if the control currently named "Roll" was changed to "Rotate" if left in the same place in the panel? It would operate exactly like it does today; only the name would change. I'll add a tooltip to explain its function. But I would also add a new control named "Roll" a bit lower, between Yaw and Perspective, which would do a true roll around the y-axis.

There are no compatibility issues with existing flames; the element is already called "rotate" for compatibility with Apophysis (which calls the control "Rotate" and doesn't have a "Roll" control).

Script compatibility is problematic; the method that sets this control is "setCamRoll", and changing how that works would break lots of existing scripts. What I propose is to deprecate "setCamRoll", meaning it would still work exactly the same as it does now, setting the control now called Rotate, but it isn't the preferred method for doing so. A new method "setRotate" would be added as the preferred and more logical way to set the rotation. Similarly, the methods "setCamPitch" and "setCamYaw" would be deprecated in favor of "setPitch" and "setYaw" which do the same thing but would be more consistent with the new "setRoll" that would set the new Roll parameter. Similar changes would be made to the corresponding "get" methods.

Second question: Would it be too confusing to have "setCamPitch" be the same as "setPitch" and "setCamYaw" be the same as "setYaw", but "setCamRoll" be totally different from "setRoll"?

An alternative would be to keep the current name "Roll" for camera rotation, and to use a different name for roll around the y-axis. Perhaps "Roll Y" or "Roll XZ". (For the mockup I made to test the new projection matrix, I used "Roll2", but I don't really like that.)

Final questions: Does it make more sense to keep the current name "Roll" on the rotate control and not change any of the method names that scripts use? (A new method named after the control, like "setCamRollY" or "setCamRollXZ" would be added so scripts could set it.) If so, what should the new control be named?


Top
   
PostPosted: Tue Nov 19, 2019 4:43 am 
Offline
User avatar

Joined: Sun May 31, 2015 2:39 pm
Posts: 617
I think it would be too confusing if we changed up the naming. I like the idea of Roll Y or the Roll YZ (but if YZ people may think it will only work when the YZ button is selected?). Maybe have a Roll X (current?) Roll Y and a Roll Z?


Top
   
PostPosted: Tue Nov 19, 2019 6:09 am 
Offline

Joined: Fri Dec 27, 2013 2:18 am
Posts: 74
Thanks. Using Roll for rotation is actually confusing to people who know what it means! But I agree that changing the name now would confuse existing users.

To make the other names consistent with "Roll Y", they would actually be "Pitch X" and "Yaw Z".

Maybe it would work to use a different term that means the same thing as roll, like "Bank" or "List", even though they aren't normally used with pitch and yaw.


Top
   
PostPosted: Tue Nov 19, 2019 9:11 pm 
Offline
User avatar

Joined: Sun May 31, 2015 2:39 pm
Posts: 617
Quote:
Thanks. Using Roll for rotation is actually confusing to people who know what it means! But I agree that changing the name now would confuse existing users.

To make the other names consistent with "Roll Y", they would actually be "Pitch X" and "Yaw Z".

Maybe it would work to use a different term that means the same thing as roll, like "Bank" or "List", even though they aren't normally used with pitch and yaw.
I like Bank


Top
   
PostPosted: Wed Nov 20, 2019 3:45 pm 
Offline

Joined: Fri Dec 27, 2013 2:18 am
Posts: 74
I'm liking bank too. That's what I'll use. Thanks.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 5 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited
Theme Created by HOLLYSMOKE
Theme updated to phpBB 3.1.6 by KamijouTouma
Theme Version is 3.1.6-ss2